Der SVerweis ist eine der komplizierteren Funktionen in Excel. Wenn die Daten nicht genau richtig aufbereitet werden, funktioniert der SVerweis nicht – deshalb wird er von vielen nicht gemocht, obwohl er eine sehr hilfreiche Funktion ist.

Ich erkläre dir, wie der SVerweis funktioniert und zeige dir auch ein Beispiel für die Anwendung.

Was tut der Excel SVerweis?

Der SVerweis in Excel wird verwendet, wenn man eine Reihe von Daten durchsuchen möchte, um einen dazugehörigen Wert zu finden. Das „S“ steht dabei für senkrecht, d. h. die Daten werden von oben nach unten durchsucht.

Man kann also zum Beispiel in einer Tabelle anhand einer Kundennummer nach dem entsprechenden Kunden suchen. Oder wenn man wissen möchte, welcher Zinssatz für ein bestimmtes Guthaben gezahlt wird, kann man den SVerweis nutzen.

Im Englischen heißt der SVerweis übrigens VLookup, was mit „nachschlagen“ übersetzt werden kann. Das „V“ steht hier für „vertical“, also senkrecht. Das beschreibt die Funktion eigentlich viel besser als unsere deutsche Bezeichnung.

Anwendung

Du benötigst folgende Daten:

  1. Das Suchkriterium bzw. den Nachschlagewert.
  2. Die Matrix, also den Bereich, in dem sich die Werte befinden.
  3. Den Spaltenindex: Die Spalte, in der der Wert steht, der ausgegeben werden soll.
  4. Optional: Bereich_Verweis (dazu weiter unten mehr).

Konkret sieht das so aus:
Beispiel Kundennummer – Kundenname

SVerweis Beispiel Tabelle

Die Kundennummer wäre dein Suchkriterium.

Die Zellen, in denen die Daten stehen, ist die Matrix (also eigentlich die ganze Tabelle).

Die Kundennamen sind die Werte, die ausgegeben werden sollen. Entsprechend ist die Spalte, in der die Kundennamen stehen, die Spalte für die Ausgabewerte. Dabei ist immer die Spalte die Nummer 1, in der die Suchkriterien stehen (auch wenn diese in Spalte C stehen und nicht in A wie in meinem Beispiel).

Wenn du also zum Beispiel die Kundennummer hast und den dazugehörigen Kunden suchst (siehe Tabelle oben), kannst du den SVerweis nehmen.

Die fertige Formel für das obige Beispiel würde so aussehen:
=SVERWEIS(B9;A3:B7;2)

Die Formel selbst könnte in der Zelle B 10 stehen.

Wenn man nun in der Zelle B9 eine Kundennummer eingibt, wird in B10 der Kundenname ausgegeben:

SVerweis Beispiel

Erklärung der Formel im Detail

Die Formel ist folgendermaßen aufgebaut:
=SVERWEIS(Suchkriterium;Matrix;Spaltenindex;[Bereich_Verweis])

=SVERWEIS ist einfach nur der Name der Funktion.

Das Suchkriterium (B9) ist die Zelle, in die die Kundennummer eingegeben wird, nach der wir suchen.

Die Matrix (A3:B7) ist der Bereich, in dem die Werte stehen, die durchsucht werden sollen.

Der Spaltenindex (2) ist die Spalte, in der unser Ausgabewert (also das Ergebnis = der Kundenname) steht.

Wichtig:
Das Suchkriterium (also in unserem Fall die Kundennummer) muss immer in der ersten Spalte der Tabelle stehen, die Ausgabewerte in den Spalten danach.

Oder anders gesagt: Die Suchkriterien müssen links von den Ausgabewerten stehen. Die Spalte, in der die Suchkriterien stehen, ist immer Spalte 1, auch wenn sie in Spalte C stehen.

Optional: Wahr und falsch (Bereich_Verweis)

Wahr und falsch (Bereich_Verweis)

Optional kannst du als 4. Wert in der Formel noch WAHR angeben, wenn dir eine ungefähre Übereinstimmung reicht – oder den Wert FALSCH, wenn du eine genaue Übereinstimmung möchtest.

In unserem Beispiel: Wir möchten eine genaue Übereinstimmung, weil die Kundennummer individuell für einen Kunden gilt. Wir würden also den Wert „Falsch“ mitangeben:

=SVERWEIS(B9;A3:B7;2;FALSCH)

Wenn wir den vierten Wert (also wahr oder falsch) nicht mit angeben, geht Excel davon aus, dass uns eine ungefähre Übereinstimmung reicht. Im folgenden Beispiel wäre das ein Problem:

SVerweis wahr falsch, Bereich_Verweis

Die Kundennummer 126 gibt es nicht. Wenn wir den vierten Wert nicht angeben oder „wahr“ angeben, wird uns trotzdem ein Kundenname ausgegeben (siehe oben), weil Excel nun davon ausgeht, dass eine ungefähre Übereinstimmung reicht.

Wenn wir aber den Wert „Falsch“ angeben, gibt Excel eine Fehlermeldung aus:
=SVERWEIS(B9;A3:B7;2;FALSCH)

SVerweis in Excel mit Wert falsch

Das ist in diesem Fall auch richtig, weil die Kundennummer 126 ja nicht existiert.

Der SVerweis in Excel mit Beispiel.